Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: apt-move

apt-move (4.2.27-5ubuntu2) focal; urgency=high * No change rebuild against apt 1.9.11. -- Julian Andres Klode <juliank@ubuntu.com> Thu, 27 Feb 2020 09:13:40 +0100 apt-move (4.2.27-5ubuntu1) eoan; urgency=medium * Port to apt 1.9 -- Julian Andres Klode <juliank@ubuntu.com> Mon, 17 Jun 2019 23:07:10 +0200

Modifications :
  1. Download patch debian/control

    --- 4.2.27-5/debian/control 2016-02-23 12:18:17.000000000 +0000 +++ 4.2.27-5ubuntu2/debian/control 2019-06-17 21:07:10.000000000 +0000 @@ -1,7 +1,8 @@ Source: apt-move Section: admin Priority: optional -Maintainer: Debian QA Group <packages@qa.debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Debian QA Group <packages@qa.debian.org> Standards-Version: 3.9.7 Build-Depends: debhelper (>= 9), libapt-pkg-dev (>= 0.6.42) Homepage: http://sourceforge.net/projects/apt-move/
  2. Download patch debian/patches/series

    --- 4.2.27-5/debian/patches/series 2016-11-02 04:34:17.000000000 +0000 +++ 4.2.27-5ubuntu2/debian/patches/series 2019-06-17 21:06:16.000000000 +0000 @@ -4,3 +4,4 @@ add-copydir.patch fix_perl_implicit_split_deprecation.patch fix-makefile.patch drop-contents-header.patch +apt-1.9.patch
  3. Download patch debian/patches/apt-1.9.patch

    --- 4.2.27-5/debian/patches/apt-1.9.patch 1970-01-01 00:00:00.000000000 +0000 +++ 4.2.27-5ubuntu2/debian/patches/apt-1.9.patch 2019-06-17 21:06:45.000000000 +0000 @@ -0,0 +1,34 @@ +Description: Port to apt 1.9 + Minor changes +Author: Julian Andres Klode <juliank@ubuntu.com> +--- apt-move-4.2.27.orig/fetch.cc ++++ apt-move-4.2.27/fetch.cc +@@ -1,9 +1,11 @@ + #include <apt-pkg/acquire-item.h> + #include <apt-pkg/cachefile.h> ++#include <apt-pkg/configuration.h> + #include <apt-pkg/error.h> + #include <apt-pkg/fileutl.h> + #include <apt-pkg/init.h> + #include <apt-pkg/pkgcache.h> ++#include <apt-pkg/pkgsystem.h> + #include <apt-pkg/progress.h> + #include <apt-pkg/sourcelist.h> + #include <iostream> +@@ -13,6 +15,7 @@ + using std::cerr; + using std::cout; + using std::endl; ++using std::string; + + typedef pkgCache::VerIterator VerIterator; + typedef pkgCache::VerFileIterator VerFileIterator; +@@ -43,7 +46,7 @@ VerIterator getHighestVersion(pkgCache & + bool downloadPackages(int test, int argc, char **argv) { + pkgCacheFile cache; + OpTextProgress prog(*_config); +- if (!cache.Open(prog, false)) ++ if (!cache.Open(&prog, false)) + return false; + + pkgRecords rec(cache);
  1. apt-move