Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: nxcl

nxcl (0.9-3.1ubuntu4) focal; urgency=medium * No-change rebuild for libgcc-s1 package name change. -- Matthias Klose <doko@ubuntu.com> Tue, 24 Mar 2020 15:08:30 +0100 nxcl (0.9-3.1ubuntu3) bionic; urgency=high * No change rebuild to pick up -fPIE compiler default -- Balint Reczey <rbalint@ubuntu.com> Tue, 03 Apr 2018 12:37:24 +0000 nxcl (0.9-3.1ubuntu2) wily; urgency=medium * Rename library packages for g++5 ABI transition. -- Iain Lane <iain@orangesquash.org.uk> Tue, 04 Aug 2015 11:32:44 +0100 nxcl (0.9-3.1ubuntu1) quantal; urgency=low * Merge from Debian unstable. Remaining changes: - Disable strict host key checking so qtnx doesn't hang. -- Michael Bienia <geser@ubuntu.com> Sun, 30 Sep 2012 13:51:34 +0200

Modifications :
  1. Download patch debian/control

    --- 0.9-3.1/debian/control 2020-03-24 23:14:19.000000000 +0000 +++ 0.9-3.1ubuntu4/debian/control 2020-03-24 23:14:20.000000000 +0000 @@ -1,14 +1,17 @@ Source: nxcl Priority: optional -Maintainer: Matthew Johnson <mjj29@debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Matthew Johnson <mjj29@debian.org> Build-Depends: debhelper (>=5), automake, autoconf, doxygen, libstdc++-dev, libdbus-1-dev, libx11-dev, quilt (>= 0.40), libtool Standards-Version: 3.7.3 Section: x11 -Package: libnxcl1 +Package: libnxcl1v5 Section: x11 Architecture: any Depends: ${shlibs:Depends}, ${misc:Depends}, ssh-client, nxproxy +Conflicts: libnxcl1 +Replaces: libnxcl1 Description: NX X compression client library NX provides a differential X compression system for X11. . @@ -17,7 +20,7 @@ Description: NX X compression client lib Package: libnxcl-dev Section: libdevel Architecture: any -Depends: libnxcl1 (= ${binary:Version}), ${misc:Depends} +Depends: libnxcl1v5 (= ${binary:Version}), ${misc:Depends} Description: NX X compression client library---headers NX provides a differential X compression system for X11. . @@ -31,4 +34,3 @@ Description: NX X compression client lib NX provides a differential X compression system for X11. . This package provides the runtime binaries for the nx client libraries. -
  2. Download patch debian/libnxcl1v5.install

    --- 0.9-3.1/debian/libnxcl1v5.install 1970-01-01 00:00:00.000000000 +0000 +++ 0.9-3.1ubuntu4/debian/libnxcl1v5.install 2020-03-24 23:14:20.000000000 +0000 @@ -0,0 +1,2 @@ +usr/lib/libnxcl.so.1.0.0 +usr/lib/libnxcl.so.1
  3. Download patch debian/patches/no-keycheck

    --- 0.9-3.1/debian/patches/no-keycheck 1970-01-01 00:00:00.000000000 +0000 +++ 0.9-3.1ubuntu4/debian/patches/no-keycheck 2020-03-24 23:14:20.000000000 +0000 @@ -0,0 +1,12 @@ +=== modified file 'nxcl/lib/nxclientlib.cpp' +--- nxcl/lib/nxclientlib.cpp 2011-02-22 15:16:47 +0000 ++++ nxcl/lib/nxclientlib.cpp 2011-02-22 15:18:46 +0000 +@@ -243,6 +243,7 @@ + arguments.push_back ("-oRSAAuthentication no"); + arguments.push_back ("-oRhostsRSAAuthentication no"); + arguments.push_back ("-oPubkeyAuthentication yes"); ++ arguments.push_back ("-oStrictHostKeyChecking no"); + // FF-FIXME: Perhaps the user wants to login as user directly + //arguments.push_back ("-c nxserver"); + +
  4. Download patch debian/patches/series

    --- 0.9-3.1/debian/patches/series 2020-03-24 23:14:19.000000000 +0000 +++ 0.9-3.1ubuntu4/debian/patches/series 2020-03-24 23:14:20.000000000 +0000 @@ -1,3 +1,4 @@ nxproxy-stdin gcc4.3-ftbfs gcc-4.7.patch +no-keycheck
  5. Download patch debian/libnxcl1.install

    --- 0.9-3.1/debian/libnxcl1.install 2020-03-24 23:14:19.000000000 +0000 +++ 0.9-3.1ubuntu4/debian/libnxcl1.install 1970-01-01 00:00:00.000000000 +0000 @@ -1,2 +0,0 @@ -usr/lib/libnxcl.so.1.0.0 -usr/lib/libnxcl.so.1
  6. Download patch debian/libnxcl1v5.lintian-overrides

    --- 0.9-3.1/debian/libnxcl1v5.lintian-overrides 1970-01-01 00:00:00.000000000 +0000 +++ 0.9-3.1ubuntu4/debian/libnxcl1v5.lintian-overrides 2020-03-24 23:14:20.000000000 +0000 @@ -0,0 +1,2 @@ +# G++5 ABI transition +libnxcl1v5: package-name-doesnt-match-sonames libnxcl1
  1. nxcl