Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: coinor-flopc++

coinor-flopc++ (1.0.6-3.1ubuntu3) wily; urgency=medium * No-change rebuild against coinor-libcoinutils3v5 -- Steve Langasek <steve.langasek@ubuntu.com> Thu, 13 Aug 2015 01:00:49 +0000 coinor-flopc++ (1.0.6-3.1ubuntu2) wily; urgency=medium * Rename library packages for g++5 ABI transition. -- Steve Langasek <steve.langasek@ubuntu.com> Mon, 03 Aug 2015 21:09:21 +0000 coinor-flopc++ (1.0.6-3.1ubuntu1) trusty; urgency=medium * Patch configure to support ppc64el. -- Matthias Klose <doko@ubuntu.com> Sat, 28 Dec 2013 01:40:19 +0100 coinor-flopc++ (1.0.6-3.1build1) trusty; urgency=medium * No-change rebuild for coinutils transition. -- Logan Rosen <logan@ubuntu.com> Sun, 22 Dec 2013 16:11:17 -0500

Modifications :
  1. Download patch debian/coinor-libflopc++0v5.lintian-overrides

    --- 1.0.6-3.1/debian/coinor-libflopc++0v5.lintian-overrides 1970-01-01 00:00:00.000000000 +0000 +++ 1.0.6-3.1ubuntu3/debian/coinor-libflopc++0v5.lintian-overrides 2015-08-14 01:06:24.000000000 +0000 @@ -0,0 +1,4 @@ +coinor-libflopc++0v5: package-name-doesnt-match-sonames libFlopCpp0 + +# G++5 ABI transition +coinor-libflopc++0v5: package-name-doesnt-match-sonames coinor-libflopc++0
  2. Download patch FlopCpp/configure

    --- 1.0.6-3.1/FlopCpp/configure 2009-06-24 13:54:45.000000000 +0000 +++ 1.0.6-3.1ubuntu3/FlopCpp/configure 2015-08-14 01:06:24.000000000 +0000 @@ -5862,7 +5862,10 @@ x86_64-*linux*|ppc*-*linux*|powerpc*-*li x86_64-*linux*) LD="${LD-ld} -m elf_i386" ;; - ppc64-*linux*|powerpc64-*linux*) + powerpc64le-*) + LD="${LD-ld} -m elf32lppclinux" + ;; + powerpc64-*) LD="${LD-ld} -m elf32ppclinux" ;; s390x-*linux*) @@ -5878,7 +5881,10 @@ x86_64-*linux*|ppc*-*linux*|powerpc*-*li x86_64-*linux*) LD="${LD-ld} -m elf_x86_64" ;; - ppc*-*linux*|powerpc*-*linux*) + powerpcle-*) + LD="${LD-ld} -m elf64lppc" + ;; + powerpc-*) LD="${LD-ld} -m elf64ppc" ;; s390*-*linux*)
  3. Download patch debian/coinor-libflopc++0.lintian-overrides

    --- 1.0.6-3.1/debian/coinor-libflopc++0.lintian-overrides 2015-08-14 01:06:23.000000000 +0000 +++ 1.0.6-3.1ubuntu3/debian/coinor-libflopc++0.lintian-overrides 1970-01-01 00:00:00.000000000 +0000 @@ -1,2 +0,0 @@ -coinor-libflopc++0: package-name-doesnt-match-sonames libFlopCpp0 -
  4. Download patch debian/control

    --- 1.0.6-3.1/debian/control 2015-08-14 01:06:23.000000000 +0000 +++ 1.0.6-3.1ubuntu3/debian/control 2015-08-14 01:06:24.000000000 +0000 @@ -1,7 +1,8 @@ Source: coinor-flopc++ Section: science Priority: extra -Maintainer: Soeren Sonnenburg <sonne@debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Soeren Sonnenburg <sonne@debian.org> Build-Depends: cdbs, debhelper (>= 5), doxygen, graphviz, coinor-libcoinutils-dev (>= 2.6.0-2), coinor-libosi-dev (>= 0.102.1) Standards-Version: 3.9.1.0 @@ -9,9 +10,11 @@ Homepage: https://projects.coin-or.org/C Vcs-Svn: http://bollin.googlecode.com/svn/coinor-clp/trunk/ Vcs-Browser: http://bollin.googlecode.com/svn/coinor-clp/trunk/ -Package: coinor-libflopc++0 +Package: coinor-libflopc++0v5 Architecture: any Depends: ${shlibs:Depends}, ${misc:Depends} +Conflicts: coinor-libflopc++0 +Replaces: coinor-libflopc++0 Description: Formulation of Linear Optimization Problems in C++ An open source algebraic modelling language implemented as a C++ class library. Using FLOPC++, linear optimization models can be specified in @@ -28,7 +31,7 @@ Description: Formulation of Linear Optim Package: coinor-libflopc++-dev Section: libdevel Architecture: any -Depends: ${shlibs:Depends}, ${misc:Depends}, coinor-libflopc++0 (= ${binary:Version}) +Depends: ${shlibs:Depends}, ${misc:Depends}, coinor-libflopc++0v5 (= ${binary:Version}) Description: Formulation of Linear Optimization Problems in C++ An open source algebraic modelling language implemented as a C++ class library. Using FLOPC++, linear optimization models can be specified in @@ -61,10 +64,12 @@ Description: Formulation of Linear Optim This package contains the documentation and examples. -Package: coinor-libflopc++0-dbg +Package: coinor-libflopc++0v5-dbg Section: debug Architecture: any -Depends: ${shlibs:Depends}, ${misc:Depends}, coinor-libflopc++0 (= ${binary:Version}) +Depends: ${shlibs:Depends}, ${misc:Depends}, coinor-libflopc++0v5 (= ${binary:Version}) +Conflicts: coinor-libflopc++0-dbg +Replaces: coinor-libflopc++0-dbg Description: Formulation of Linear Optimization Problems in C++ An open source algebraic modelling language implemented as a C++ class library. Using FLOPC++, linear optimization models can be specified in
  5. Download patch debian/coinor-libflopc++0v5-dbg.lintian-overrides

    --- 1.0.6-3.1/debian/coinor-libflopc++0v5-dbg.lintian-overrides 1970-01-01 00:00:00.000000000 +0000 +++ 1.0.6-3.1ubuntu3/debian/coinor-libflopc++0v5-dbg.lintian-overrides 2015-08-14 01:06:24.000000000 +0000 @@ -0,0 +1,2 @@ +# G++5 ABI transition +coinor-libflopc++0v5-dbg: package-name-doesnt-match-sonames coinor-libflopc++0-dbg
  6. Download patch debian/coinor-libflopc++0v5.install

    --- 1.0.6-3.1/debian/coinor-libflopc++0v5.install 1970-01-01 00:00:00.000000000 +0000 +++ 1.0.6-3.1ubuntu3/debian/coinor-libflopc++0v5.install 2015-08-14 01:06:24.000000000 +0000 @@ -0,0 +1 @@ +debian/tmp/usr/lib/lib*.so.*
  7. Download patch debian/coinor-libflopc++0.install

    --- 1.0.6-3.1/debian/coinor-libflopc++0.install 2015-08-14 01:06:23.000000000 +0000 +++ 1.0.6-3.1ubuntu3/debian/coinor-libflopc++0.install 1970-01-01 00:00:00.000000000 +0000 @@ -1 +0,0 @@ -debian/tmp/usr/lib/lib*.so.*
  1. coinor-flopc++