Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: coolkey

coolkey (1.1.0-13ubuntu2) trusty; urgency=low * Remove recommends for epiphany-browser as it no longer exists. Debian bug 736181. -- Brian Murray <brian@ubuntu.com> Tue, 28 Jan 2014 01:57:12 -0800 coolkey (1.1.0-13ubuntu1) trusty; urgency=medium * Use dh-autoreconf instead of autotools-dev to also fix FTBFS on ppc64el by getting new libtool macros (still updates config.{sub,guess}). -- Logan Rosen <logan@ubuntu.com> Sat, 18 Jan 2014 23:46:09 -0500

Modifications :
  1. Download patch debian/rules

    --- 1.1.0-13/debian/rules 2014-01-18 14:17:29.000000000 +0000 +++ 1.1.0-13ubuntu2/debian/rules 2014-01-19 04:45:57.000000000 +0000 @@ -1,19 +1,11 @@ #!/usr/bin/make -f %: - dh $@ + dh $@ --with autoreconf # copy up to date files override_dh_auto_configure: - -test -r /usr/share/misc/config.sub && \ - cp -f /usr/share/misc/config.sub config.sub - -test -r /usr/share/misc/config.guess && \ - cp -f /usr/share/misc/config.guess config.guess ( PCSC_CFLAGS=`/usr/bin/pkg-config --cflags libpcsclite` ; PCSC_LIBS=`/usr/bin/pkg-config --libs libpcsclite` ; dh_auto_configure -- --with-debug --disable-dependency-tracking ) -override_dh_auto_clean: - dh_auto_clean - rm -f config.guess config.sub - # avoid libtool -rpath problems override_dh_auto_build: sed < libtool > libtool-2 -e 's/^hardcode_libdir_flag_spec.*$$/hardcode_libdir_flag_spec=" -D__LIBTOOL_IS_A_FOOL__ "/' -e '/^archive_cmds="/s/"$$/ \\$$deplibs"/'
  2. Download patch debian/control

    --- 1.1.0-13/debian/control 2014-01-18 14:59:33.000000000 +0000 +++ 1.1.0-13ubuntu2/debian/control 2014-01-28 09:55:35.000000000 +0000 @@ -1,9 +1,10 @@ Source: coolkey Section: admin Priority: optional -Maintainer: A. Maitland Bottoms <bottoms@debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: A. Maitland Bottoms <bottoms@debian.org> Uploaders: Ludovic Rousseau <rousseau@debian.org> -Build-Depends: debhelper (>= 9~), autoconf, autotools-dev, pkg-config, zlib1g-dev, libpcsclite-dev, libnss3-dev, libnspr4-dev, dh-exec (>=0.3) +Build-Depends: debhelper (>= 9~), autoconf, dh-autoreconf, pkg-config, zlib1g-dev, libpcsclite-dev, libnss3-dev, libnspr4-dev, dh-exec (>=0.3) Standards-Version: 3.9.3 Homepage: http://directory.fedoraproject.org/wiki/CoolKey Vcs-Browser: http://anonscm.debian.org/viewvc/pkg-coolkey/coolkey/trunk/ @@ -12,7 +13,7 @@ Vcs-Svn: svn://anonscm.debian.org/pkg-co Package: coolkey Architecture: any Depends: libckyapplet1 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}, libpcsclite1 -Recommends: libnss3-tools, epiphany-extensions +Recommends: libnss3-tools Description: Smart Card PKCS #11 cryptographic module Linux Driver support for the CoolKey and Common Access Card (CAC) smart card security keys used in a Public Key Infrastructure (PKI).
  1. coolkey