Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: cpqarrayd

cpqarrayd (2.3.6ubuntu1) focal; urgency=medium * Merge from Debian unstable. Remaining changes: - debian/rules: Find Ubuntu's linux-source, too, which uses bz2 and not xz; resolves FTBFS. -- Logan Rosen <logan@ubuntu.com> Sun, 16 Feb 2020 15:45:26 -0500

Modifications :
  1. Download patch debian/rules

    --- 2.3.6/debian/rules 2018-06-01 08:37:34.000000000 +0000 +++ 2.3.6ubuntu1/debian/rules 2018-06-01 16:53:03.000000000 +0000 @@ -16,7 +16,7 @@ include /usr/share/dpkg/buildflags.mk # stuff from the linux tree :( thus the build-dep on linux-source # this is sucky way to do it but we don't have the shell's nice % and # here and I can't be bothered to do it "the make way". Patches welcome. -KSRC=$(shell ls -d $(wildcard /usr/src/linux-source-*.*.tar.xz) | tail -n1 |awk -F/usr/src/ '{print $$2}' |awk -F.tar.xz '{print $$1}') +KSRC=$(shell ls -d $(wildcard /usr/src/linux-source-*.*.tar.bz2) | tail -n1 |awk -F/usr/src/ '{print $$2}' |awk -F.tar.bz2 '{print $$1}') PWD=$(shell pwd) ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) @@ -32,7 +32,7 @@ unpack: unpack-stamp unpack-stamp: if [ -e debian/linux ]; then rm -rf debian/linux; fi mkdir debian/linux - cd debian/linux && tar xvf /usr/src/$(KSRC).tar.xz + cd debian/linux && tar xvf /usr/src/$(KSRC).tar.bz2 touch unpack-stamp config.status: configure unpack
  2. Download patch debian/control

    --- 2.3.6/debian/control 2018-06-01 08:37:34.000000000 +0000 +++ 2.3.6ubuntu1/debian/control 2020-02-16 20:45:26.000000000 +0000 @@ -1,7 +1,8 @@ Source: cpqarrayd Section: admin Priority: optional -Maintainer: Debian QA Group <packages@qa.debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Debian QA Group <packages@qa.debian.org> Build-Depends: debhelper (>= 10), linux-source, libsnmp-dev, autoconf, automake Standards-Version: 4.1.4
  1. cpqarrayd