Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: fwupdate

fwupdate (12-3ubuntu2) cosmic; urgency=medium * debian/rules: don't process fwupdate EFI binary into signable uefi artefacts for Launchpad: signable EFI binary has moved to fwupd. -- Mathieu Trudel-Lapierre <cyphermox@ubuntu.com> Mon, 10 Sep 2018 15:00:07 -0400 fwupdate (12-3ubuntu1) cosmic; urgency=medium * No-change rebuild against gnu-efi 3.0.8. -- Mathieu Trudel-Lapierre <cyphermox@ubuntu.com> Wed, 29 Aug 2018 16:25:46 -0400

Modifications :
  1. Download patch debian/rules

    --- 12-3/debian/rules 2018-08-06 04:07:22.000000000 +0000 +++ 12-3ubuntu2/debian/rules 2018-09-10 18:58:55.000000000 +0000 @@ -68,17 +68,6 @@ endif override_dh_auto_clean: dh_auto_clean -- EFIDIR=$(EFIDIR) -ifeq (ubuntu,$(SB_STYLE)) - rm -rf debian/fwupdate-images -endif override_dh_builddeb: dh_builddeb -- -Zxz -ifeq (ubuntu,$(SB_STYLE)) - mkdir -p debian/fwupdate-images/$(deb_version) - cp efi/fwup*.efi debian/fwupdate-images/$(deb_version) - echo $(deb_version) \ - > debian/fwupdate-images/$(deb_version)/version - cd debian/fwupdate-images && tar czvf ../../../$(tar_name) . - dpkg-distaddfile $(tar_name) raw-uefi - -endif
  2. Download patch debian/control

    --- 12-3/debian/control 2018-08-06 04:02:24.000000000 +0000 +++ 12-3ubuntu2/debian/control 2018-08-29 20:25:46.000000000 +0000 @@ -1,6 +1,7 @@ Source: fwupdate Priority: optional -Maintainer: Debian EFI <debian-efi@lists.debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Debian EFI <debian-efi@lists.debian.org> Uploaders: Daniel Jared Dominguez <jared.dominguez@dell.com>, Steve McIntyre <93sam@debian.org>, Mario Limonciello <mario.limonciello@dell.com> Build-Depends: debhelper (>= 9.0.0), pkg-config, libpopt-dev, libefivar-dev (>= 34), libefiboot-dev (>= 34), gnu-efi (>= 3.0.2), elfutils, libsmbios-dev [amd64 i386] Standards-Version: 4.1.3
  1. fwupdate