Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: php-horde-auth

php-horde-auth (2.2.2-1ubuntu1) bionic; urgency=medium * debian/patches/phpunit6_compatibility.patch: PHPUnit6 has replaced getMock with createMock. -- Nishanth Aravamudan <nish.aravamudan@canonical.com> Thu, 15 Feb 2018 16:29:56 -0800

Modifications :
  1. Download patch debian/patches/phpunit6_compatibility.patch

    --- 2.2.2-1/debian/patches/phpunit6_compatibility.patch 1970-01-01 00:00:00.000000000 +0000 +++ 2.2.2-1ubuntu1/debian/patches/phpunit6_compatibility.patch 2018-02-16 00:29:50.000000000 +0000 @@ -0,0 +1,16 @@ +Description: PHPUnit6 has replaced getMock with createMock +Author: Nishanth Aravamudan <nish.aravamudan@canonical.com> +Forwarded: Will be done by Nishanth Aravamudan +Last-Update: 2018-02-16 + +--- php-horde-auth-2.2.2.orig/Horde_Auth-2.2.2/test/Horde/Auth/Unit/KolabTest.php ++++ php-horde-auth-2.2.2/Horde_Auth-2.2.2/test/Horde/Auth/Unit/KolabTest.php +@@ -21,7 +21,7 @@ class Horde_Auth_Unit_KolabTest extends + if (!interface_exists('Horde_Kolab_Session')) { + $this->markTestSkipped('The Kolab_Session package is apparently not installed (Interface Horde_Kolab_Session is unavailable).'); + } +- $this->kolab = $this->getMock('Horde_Kolab_Session'); ++ $this->kolab = $this->createMock('Horde_Kolab_Session'); + $this->driver = new Horde_Auth_Kolab(array('kolab' => $this->kolab)); + } +
  2. Download patch debian/control

    --- 2.2.2-1/debian/control 2017-06-30 19:08:37.000000000 +0000 +++ 2.2.2-1ubuntu1/debian/control 2018-02-16 00:29:56.000000000 +0000 @@ -1,7 +1,8 @@ Source: php-horde-auth Section: php Priority: extra -Maintainer: Horde Maintainers <pkg-horde-hackers@lists.alioth.debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Horde Maintainers <pkg-horde-hackers@lists.alioth.debian.org> Uploaders: Mathieu Parent <sathieu@debian.org> Build-Depends: debhelper (>= 9), pkg-php-tools, pear-horde-channel Standards-Version: 3.9.8
  3. Download patch debian/patches/series

    --- 2.2.2-1/debian/patches/series 1970-01-01 00:00:00.000000000 +0000 +++ 2.2.2-1ubuntu1/debian/patches/series 2018-02-16 00:29:21.000000000 +0000 @@ -0,0 +1 @@ +phpunit6_compatibility.patch
  1. php-horde-auth