Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: purpose

purpose (5.78.0-2ubuntu1) hirsute; urgency=medium * Merge from debian unstable. Remaining changes: - Kubuntu Vcs fields. - Depends qml-module-ubuntu-onlineaccounts. - Breaks/Replaces libkf5purpose-bin (<< 5.70.0-1~) -- Rik Mills <rikmills@kde.org> Fri, 29 Jan 2021 22:06:24 +0000

Modifications :
  1. Download patch debian/control

    --- 5.78.0-2/debian/control 2021-01-17 02:54:34.000000000 +0000 +++ 5.78.0-2ubuntu1/debian/control 2021-01-29 22:06:24.000000000 +0000 @@ -3,7 +3,7 @@ Section: libs Priority: optional Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Uploaders: Maximiliano Curia <maxy@debian.org>, - Norbert Preining <norbert@preining.info> + Norbert Preining <norbert@preining.info>, Build-Depends: cmake (>= 3.5~), debhelper-compat (= 13), extra-cmake-modules (>= 5.78.0~), @@ -17,15 +17,15 @@ Build-Depends: cmake (>= 3.5~), libkf5coreaddons-dev (>= 5.78.0~), libkf5i18n-dev (>= 5.78.0~), libkf5kio-dev (>= 5.78.0~), - libkf5notifications-dev, + libkf5notifications-dev (>= 5.78.0~), pkg-config, pkg-kde-tools (>= 0.15.15ubuntu1~), qtbase5-dev (>= 5.14.0~), - qtdeclarative5-dev (>= 5.14.0~) + qtdeclarative5-dev (>= 5.14.0~), Standards-Version: 4.5.1 Homepage: https://invent.kde.org/frameworks/purpose -Vcs-Browser: https://salsa.debian.org/qt-kde-team/kde/purpose -Vcs-Git: https://salsa.debian.org/qt-kde-team/kde/purpose.git +Vcs-Browser: https://code.launchpad.net/~kubuntu-packagers/kubuntu-packaging/+git/purpose +Vcs-Git: https://git.launchpad.net/~kubuntu-packagers/kubuntu-packaging/+git/purpose Rules-Requires-Root: no Package: libkf5purpose-bin @@ -34,8 +34,9 @@ Multi-Arch: same Depends: qml-module-org-kde-bluezqt (>= 5.70.0~) [linux-any], qml-module-org-kde-kquickcontrolsaddons (>= 5.70.0~), qml-module-qtquick-dialogs, + qml-module-ubuntu-onlineaccounts, ${misc:Depends}, - ${shlibs:Depends} + ${shlibs:Depends}, Suggests: kdeconnect Description: abstraction to provide and leverage actions of a specific kind, runtime Purpose offers the possibility to create integrate services and actions on @@ -53,7 +54,7 @@ Multi-Arch: same Depends: libkf5coreaddons-dev (>= 5.78.0~), libkf5purpose5 (= ${binary:Version}), qtbase5-dev (>= 5.14.0~), - ${misc:Depends} + ${misc:Depends}, Description: abstraction to provide and leverage actions of a specific kind, devel files Purpose offers the possibility to create integrate services and actions on any application without having to implement them specifically. Purpose will @@ -69,9 +70,11 @@ Multi-Arch: same Depends: qml-module-org-kde-kquickcontrolsaddons (>= 5.70.0~), qml-module-qtquick-controls2, ${misc:Depends}, - ${shlibs:Depends} + ${shlibs:Depends}, Recommends: libkf5purpose-bin, qml-module-org-kde-purpose (= ${binary:Version}) Suggests: kde-telepathy-send-file +Breaks: libkf5purpose-bin (<< 5.70.0-1~) +Replaces: libkf5purpose-bin (<< 5.70.0-1~) Description: library for abstractions to get the developer's purposes fulfilled Framework for providing abstractions to get the developer's purposes fulfilled. . @@ -85,7 +88,7 @@ Depends: qml-module-qtquick-controls, qml-module-qtquick-layouts, qml-module-qtquick2, ${misc:Depends}, - ${shlibs:Depends} + ${shlibs:Depends}, Recommends: kdeconnect Description: abstraction to provide and leverage actions of a specific kind, qml bindings Purpose offers the possibility to create integrate services and actions on
  1. purpose