Debian

Available patches from Ubuntu

To see Ubuntu differences wrt. to Debian, write down a grep-dctrl query identifying the packages you're interested in:
grep-dctrl -n -sPackage Sources.Debian
(e.g. -FPackage linux-ntfs or linux-ntfs)

Modified packages are listed below:

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: totem

totem (3.38.0-2ubuntu1) hirsute; urgency=medium * Resynchronize with debian, remaining changes are - debian/control.in: + Use ubuntu-desktop vcs - debian/gbp.conf: Use ubuntu settings - Add dont-make-compulsory.patch: + Allow Totem to be uninstalled from the GNOME Software app. - Add 91_quicklist_entries.patch: + Add static quicklist. - Add Add-Mute-action.patch: + Add Mute action so that we can use it as a Desktop Action -- Sebastien Bacher <seb128@ubuntu.com> Fri, 22 Jan 2021 16:58:39 +0100

Modifications :
  1. Download patch debian/patches/91_quicklist_entries.patch

    --- 3.38.0-2/debian/patches/91_quicklist_entries.patch 1970-01-01 00:00:00.000000000 +0000 +++ 3.38.0-2ubuntu1/debian/patches/91_quicklist_entries.patch 2020-09-15 01:05:46.000000000 +0000 @@ -0,0 +1,45 @@ +From: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +Date: Fri, 24 Aug 2018 14:29:48 +0300 +Subject: _quicklist_entries +MIME-Version: 1.0 +Content-Type: text/plain; charset="utf-8" +Content-Transfer-Encoding: 8bit + +Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/totem/+bug/938031 +Origin: vendor +Forwarded: https://bugzilla.gnome.org/671088 +Reviewed-By: Stéphane Graber <stgraber@ubuntu.com> +--- + data/org.gnome.Totem.desktop.in.in | 22 ++++++++++++++++++++++ + 1 file changed, 22 insertions(+) + +diff --git a/data/org.gnome.Totem.desktop.in.in b/data/org.gnome.Totem.desktop.in.in +index 0e3b6bd..d338e42 100644 +--- a/data/org.gnome.Totem.desktop.in.in ++++ b/data/org.gnome.Totem.desktop.in.in +@@ -18,3 +18,25 @@ X-GNOME-Bugzilla-Version=@VERSION@ + X-GNOME-Bugzilla-OtherBinaries=totem-video-thumbnailer; + StartupNotify=true + MimeType=@MIME_TYPE@ ++ ++Actions=play;next-chapter;previous-chapter;mute;fullscreen; ++ ++[Desktop Action play] ++Name=Play/Pause ++Exec=totem --play-pause ++ ++[Desktop Action next-chapter] ++Name=Next ++Exec=totem --next ++ ++[Desktop Action previous-chapter] ++Name=Previous ++Exec=totem --previous ++ ++[Desktop Action mute] ++Name=Mute ++Exec=totem --mute ++ ++[Desktop Action fullscreen] ++Name=Fullscreen ++Exec=totem --fullscreen
  2. Download patch debian/patches/Add-Mute-action.patch

    --- 3.38.0-2/debian/patches/Add-Mute-action.patch 1970-01-01 00:00:00.000000000 +0000 +++ 3.38.0-2ubuntu1/debian/patches/Add-Mute-action.patch 2020-09-15 01:05:46.000000000 +0000 @@ -0,0 +1,36 @@ +From: Simone Piccardi <simone.piccardi@gmail.com> +Date: Tue, 15 Jan 2019 15:30:16 -0500 +Subject: Add Mute action + +Forwarded: https://gitlab.gnome.org/GNOME/totem/merge_requests/32 +--- + src/totem-menu.c | 9 +++++++++ + 1 file changed, 9 insertions(+) + +diff --git a/src/totem-menu.c b/src/totem-menu.c +index 388db64..9d57301 100644 +--- a/src/totem-menu.c ++++ b/src/totem-menu.c +@@ -296,6 +296,14 @@ remote_command_cb (GSimpleAction *action, + totem_object_remote_command (totem, cmd, url); + } + ++static void ++mute_action_cb (GSimpleAction *action, ++ GVariant *parameter, ++ gpointer user_data) ++{ ++ TOTEM_PROFILE (totem_object_volume_toggle_mute (TOTEM_OBJECT (user_data))); ++} ++ + static GActionEntry app_entries[] = { + /* Main app menu */ + { "open", open_action_cb, NULL, NULL, NULL }, +@@ -306,6 +314,7 @@ static GActionEntry app_entries[] = { + { "shortcuts", keyboard_shortcuts_action_cb, NULL, NULL, NULL }, + { "help", help_action_cb, NULL, NULL, NULL }, + { "quit", quit_action_cb, NULL, NULL, NULL }, ++ { "mute", mute_action_cb, NULL, NULL, NULL }, + + /* "Go" menu */ + { "dvd-root-menu", dvd_root_menu_action_cb, NULL, NULL, NULL },
  3. Download patch debian/patches/dont-make-compulsory.patch

    --- 3.38.0-2/debian/patches/dont-make-compulsory.patch 1970-01-01 00:00:00.000000000 +0000 +++ 3.38.0-2ubuntu1/debian/patches/dont-make-compulsory.patch 2020-09-15 01:05:46.000000000 +0000 @@ -0,0 +1,21 @@ +From: Jeremy Bicha <jbicha@ubuntu.com> +Date: Wed, 4 Apr 2018 10:19:30 -0400 +Subject: Allow users to uninstall Totem using the GNOME Software app + +since we explicitly allow it to be removed in our minimal install option +--- + data/appdata/org.gnome.Totem.appdata.xml.in | 1 - + 1 file changed, 1 deletion(-) + +diff --git a/data/appdata/org.gnome.Totem.appdata.xml.in b/data/appdata/org.gnome.Totem.appdata.xml.in +index 4c1eea8..c73543c 100644 +--- a/data/appdata/org.gnome.Totem.appdata.xml.in ++++ b/data/appdata/org.gnome.Totem.appdata.xml.in +@@ -32,7 +32,6 @@ + <update_contact>hadess@hadess.net</update_contact> + <developer_name>The GNOME developers</developer_name> + <project_group>GNOME</project_group> +- <compulsory_for_desktop>GNOME</compulsory_for_desktop> + <translation type="gettext">totem</translation> + <launchable type="desktop-id">org.gnome.Totem.desktop</launchable> + <releases>
  4. Download patch debian/control

    --- 3.38.0-2/debian/control 2020-11-23 10:17:46.000000000 +0000 +++ 3.38.0-2ubuntu1/debian/control 2021-01-22 15:58:39.000000000 +0000 @@ -5,7 +5,8 @@ Source: totem Section: video Priority: optional -Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> Uploaders: Jeremy Bicha <jbicha@debian.org>, Laurent Bigonville <bigon@debian.org> Build-Depends: appstream-util, debhelper-compat (= 13), @@ -48,8 +49,10 @@ Build-Depends: appstream-util, Build-Depends-Indep: libgdk-pixbuf2.0-doc, libglib2.0-doc, libgtk-3-doc Rules-Requires-Root: no Standards-Version: 4.5.0 -Vcs-Browser: https://salsa.debian.org/gnome-team/totem -Vcs-Git: https://salsa.debian.org/gnome-team/totem.git +XS-Debian-Vcs-Browser: https://salsa.debian.org/gnome-team/totem +XS-Debian-Vcs-Git: https://salsa.debian.org/gnome-team/totem.git +Vcs-Browser: https://salsa.debian.org/gnome-team/totem/tree/ubuntu/master +Vcs-Git: https://salsa.debian.org/gnome-team/totem.git -b ubuntu/master Homepage: https://wiki.gnome.org/Apps/Videos Package: libtotem0
  5. Download patch debian/control.in

    --- 3.38.0-2/debian/control.in 2020-11-23 10:17:46.000000000 +0000 +++ 3.38.0-2ubuntu1/debian/control.in 2021-01-22 15:58:08.000000000 +0000 @@ -1,7 +1,8 @@ Source: totem Section: video Priority: optional -Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> Uploaders: @GNOME_TEAM@ Build-Depends: appstream-util, debhelper-compat (= 13), @@ -44,8 +45,10 @@ Build-Depends: appstream-util, Build-Depends-Indep: libgdk-pixbuf2.0-doc, libglib2.0-doc, libgtk-3-doc Rules-Requires-Root: no Standards-Version: 4.5.0 -Vcs-Browser: https://salsa.debian.org/gnome-team/totem -Vcs-Git: https://salsa.debian.org/gnome-team/totem.git +XS-Debian-Vcs-Browser: https://salsa.debian.org/gnome-team/totem +XS-Debian-Vcs-Git: https://salsa.debian.org/gnome-team/totem.git +Vcs-Browser: https://salsa.debian.org/gnome-team/totem/tree/ubuntu/master +Vcs-Git: https://salsa.debian.org/gnome-team/totem.git -b ubuntu/master Homepage: https://wiki.gnome.org/Apps/Videos Package: libtotem0
  6. Download patch debian/patches/series

    --- 3.38.0-2/debian/patches/series 2020-11-23 10:17:46.000000000 +0000 +++ 3.38.0-2ubuntu1/debian/patches/series 2020-09-15 01:05:46.000000000 +0000 @@ -1,2 +1,5 @@ -debian/Don-t-run-pylint-at-build-time.patch test-totem-Properly-handle-menu-text-for-undetermined-lan.patch +debian/Don-t-run-pylint-at-build-time.patch +dont-make-compulsory.patch +91_quicklist_entries.patch +Add-Mute-action.patch
  7. Download patch debian/gbp.conf

    --- 3.38.0-2/debian/gbp.conf 2020-11-23 10:17:46.000000000 +0000 +++ 3.38.0-2ubuntu1/debian/gbp.conf 2020-09-15 01:05:46.000000000 +0000 @@ -1,6 +1,7 @@ [DEFAULT] pristine-tar = True -debian-branch=debian/master +debian-branch=ubuntu/master +debian-tag=ubuntu/%(version)s upstream-branch=upstream/latest [buildpackage]

Debian ( Changelog | PTS | Bugs ) Ubuntu ( Changelog | txt | LP | Bugs ) | Diff from Ubuntu

Source: totem-pl-parser

totem-pl-parser (3.26.5-5ubuntu1) groovy; urgency=medium * Merge with debian, remaining changes: - Split libtotem-plparser-videosite off to a separate package to avoid pulling all its dependencies into main - debian/control.in: + Don't have libtotem-pl-parser-dev depend on libquvi-dev -- Marco Trevisan (Treviño) <marco@ubuntu.com> Wed, 16 Sep 2020 14:53:23 +0200

Modifications :
  1. Download patch debian/libtotem-plparser-videosite.install

    --- 3.26.5-5/debian/libtotem-plparser-videosite.install 1970-01-01 00:00:00.000000000 +0000 +++ 3.26.5-5ubuntu1/debian/libtotem-plparser-videosite.install 2020-09-16 12:53:23.000000000 +0000 @@ -0,0 +1,2 @@ +# for videosite helper binary: +usr/lib/*/libtotem-plparser*/totem-pl-parser
  2. Download patch debian/control

    --- 3.26.5-5/debian/control 2020-09-16 12:30:53.000000000 +0000 +++ 3.26.5-5ubuntu1/debian/control 2020-09-16 12:53:23.000000000 +0000 @@ -5,8 +5,9 @@ Source: totem-pl-parser Section: libs Priority: optional -Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> -Uploaders: Emilio Pozuelo Monfort <pochu@debian.org>, Jeremy Bicha <jbicha@debian.org>, Michael Biebl <biebl@debian.org>, Sjoerd Simons <sjoerd@debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> +Uploaders: Emilio Pozuelo Monfort <pochu@debian.org>, Jeremy Bicha <jbicha@debian.org>, Michael Biebl <biebl@debian.org>, Sebastien Bacher <seb128@debian.org> Build-Depends: debhelper-compat (= 13), dbus <!nocheck>, gnome-pkg-tools, @@ -24,8 +25,10 @@ Build-Depends: debhelper-compat (= 13), meson (>= 0.40.1), shared-mime-info <!nocheck> Standards-Version: 4.3.0 -Vcs-Browser: https://salsa.debian.org/gnome-team/totem-pl-parser -Vcs-Git: https://salsa.debian.org/gnome-team/totem-pl-parser.git +XS-Debian-Vcs-Browser: https://salsa.debian.org/gnome-team/totem-pl-parser +XS-Debian-Vcs-Git: https://salsa.debian.org/gnome-team/totem-pl-parser.git +Vcs-Browser: https://salsa.debian.org/gnome-team/totem-pl-parser/tree/ubuntu/master +Vcs-Git: https://salsa.debian.org/gnome-team/totem-pl-parser.git -b ubuntu/master Package: libtotem-plparser-dev Section: libdevel @@ -35,7 +38,6 @@ Depends: gir1.2-totemplparser-1.0 (= ${b libtotem-plparser18 (= ${binary:Version}), libarchive-dev, libglib2.0-dev, - libquvi-0.9-dev, libxml2-dev, ${misc:Depends} Description: Totem Playlist Parser library - development files @@ -70,6 +72,19 @@ Description: Totem Playlist Parser libra . This package contains the shared library. +Package: libtotem-plparser-videosite +Architecture: any +Multi-Arch: same +Depends: ${misc:Depends}, + ${shlibs:Depends} +Breaks: libtotem-plparser18 (<< 3.10.6-4ubuntu1~) +Replaces: libtotem-plparser18 (<< 3.10.6-4ubuntu1~) +Description: Totem Playlist Parser library - videosite helper + totem-pl-parser is a simple GObject-based library to parse a host of + playlist formats, as well as save those. + . + This package contains the videosite helper. + Package: gir1.2-totemplparser-1.0 Section: introspection Architecture: any
  3. Download patch debian/control.in

    --- 3.26.5-5/debian/control.in 2020-09-16 12:30:53.000000000 +0000 +++ 3.26.5-5ubuntu1/debian/control.in 2020-09-16 12:53:23.000000000 +0000 @@ -1,7 +1,8 @@ Source: totem-pl-parser Section: libs Priority: optional -Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> +Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> +XSBC-Original-Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> Uploaders: @GNOME_TEAM@ Build-Depends: debhelper-compat (= 13), dbus <!nocheck>, @@ -20,8 +21,10 @@ Build-Depends: debhelper-compat (= 13), meson (>= 0.40.1), shared-mime-info <!nocheck> Standards-Version: 4.3.0 -Vcs-Browser: https://salsa.debian.org/gnome-team/totem-pl-parser -Vcs-Git: https://salsa.debian.org/gnome-team/totem-pl-parser.git +XS-Debian-Vcs-Browser: https://salsa.debian.org/gnome-team/totem-pl-parser +XS-Debian-Vcs-Git: https://salsa.debian.org/gnome-team/totem-pl-parser.git +Vcs-Browser: https://salsa.debian.org/gnome-team/totem-pl-parser/tree/ubuntu/master +Vcs-Git: https://salsa.debian.org/gnome-team/totem-pl-parser.git -b ubuntu/master Package: libtotem-plparser-dev Section: libdevel @@ -31,7 +34,6 @@ Depends: gir1.2-totemplparser-1.0 (= ${b libtotem-plparser18 (= ${binary:Version}), libarchive-dev, libglib2.0-dev, - libquvi-0.9-dev, libxml2-dev, ${misc:Depends} Description: Totem Playlist Parser library - development files @@ -66,6 +68,19 @@ Description: Totem Playlist Parser libra . This package contains the shared library. +Package: libtotem-plparser-videosite +Architecture: any +Multi-Arch: same +Depends: ${misc:Depends}, + ${shlibs:Depends} +Breaks: libtotem-plparser18 (<< 3.10.6-4ubuntu1~) +Replaces: libtotem-plparser18 (<< 3.10.6-4ubuntu1~) +Description: Totem Playlist Parser library - videosite helper + totem-pl-parser is a simple GObject-based library to parse a host of + playlist formats, as well as save those. + . + This package contains the videosite helper. + Package: gir1.2-totemplparser-1.0 Section: introspection Architecture: any
  4. Download patch debian/libtotem-plparser18.install

    --- 3.26.5-5/debian/libtotem-plparser18.install 2020-09-16 12:30:53.000000000 +0000 +++ 3.26.5-5ubuntu1/debian/libtotem-plparser18.install 2020-09-16 12:53:23.000000000 +0000 @@ -1,3 +1 @@ usr/lib/*/lib*.so.* -# for videosite helper binary: -usr/lib/*/libtotem-plparser*/totem-pl-parser
  5. Download patch debian/gbp.conf

    --- 3.26.5-5/debian/gbp.conf 2020-09-16 12:30:53.000000000 +0000 +++ 3.26.5-5ubuntu1/debian/gbp.conf 2020-09-16 12:53:23.000000000 +0000 @@ -1,6 +1,7 @@ [DEFAULT] pristine-tar = True -debian-branch = debian/master +debian-branch = ubuntu/master +debian-tag = ubuntu/%(version)s upstream-branch = upstream/latest [buildpackage]
  1. totem
  2. totem-pl-parser